You will be redirected to Practiscore.com. We use one sign-on for all our sites.

Welcome to Answers for Practical Shooting, where you can ask questions and receive answers from the practical shooting community.

Questions aren't limited to only Practiscore. Looking for advise on your next shot timer, what does it take to get a sponsorship, or what airline is easiest to travel on with guns. This is your place for practical shooting answers!

Practiscore has people dedicated to watching, and answering these questions.

+1 vote
I made an event and required payment at the time of registration. Everyone says they have paid already but about 1/3 of the participants aren’t showing paid in the system and there’s no record of payment in Stripe. Several have tried to pay again and they get an error code saying l  “whoops, looks like something went wrong”. Help!!
asked by (130 points)

1 Answer

0 votes
I would double check the stripe keys. we are just a portal to stripe. If your keys are correct it is probably in the stripe account. You can go to the test mode in stripe and register yourself a few times and see if the card info transfers to stripe.
answered ago by Practiscore Team member (9k points)
I could understand that being the case if none of the payments were going through but when 2/3 of the payments go through without a problem and a third of my people are having no payment go through then something else is going on. I really need help getting resolution on this because it’s making me look really bad.
...